RHEL7 Server and mod_ldap Missing

I have an RHEL7 server that uses mod_ldap. When I ran updates yesterday, I got this error:

...snip...
--> Finished Dependency Resolution
Error: Package: mod_ldap-2.4.6-90.el7.x86_64 (@rhel-7-server-optional-rpms)
Requires: httpd = 2.4.6-90.el7
Removing: httpd-2.4.6-90.el7.x86_64 (@rhel-7-server-rpms)
httpd = 2.4.6-90.el7
Updated By: httpd-2.4.6-93.el7.x86_64 (rhel-7-server-rpms)
httpd = 2.4.6-93.el7
...snip...

So, for some reason, the mod_ldap package for httpd-2.4.6-93 (which was what it was going to be updated to) was missing. I searched our satellite server and found it. I then deleted the mod_ldap package and ran all the other updates, thinking I’d just install mod_ldap when it was finished.

Note that I didn’t read this very carefully and just thought that it was moved to the optional packages. So I enabled that repo.


# subscription-manager repos --enable=rhel-7-server-optional-rpms
# yum install mod_ldap

I still got the error that there was no such mod_ldap package. Then I looked more closely at the repo. It was in the optional packages for workstation, not server. Unfortunately, I had server installed. I tried enabling the optional workstation repo, but that didn’t work, nor did I really think it would. My solution was to go to another computer that is running rhel7 workstation and install yum-utils. Then run yumdownloader mod_ldap, which downloaded the rpm for me. I copied that rpm to my server and installed it without any issues. Then, I could restart my webserver and things worked as before.